Programming error 0x43

Dear,

I have this programming error using the Industruino 1286 :

Found programmer: Id = "MT-CDC"; type = S
Programmer supports buffered memory access with buffersize=256 bytes.

    Device code: 0x43

 

Could you help me to solve it?

Cordially,

Guillem

Guillem Castellvi
Guillem Castellvi
7
| 0 0 0
Asked on 9/7/16, 8:39 AM
0
vote
817 Views

OOK!!!

What do we have here?

1286 is a different type of MCU in many ways, somehow like Leonardo it has a peculiar handling of the USB port.

You already found out that you setup Industruino 1286 programmer, did you see the separate COM port that comes up when you reset the 1286?

I was not able to load anything without setting to this port and hitting reset.

It's all well documented in 1286 datasheet, you have then 8 seconds to start download.

So it's a bit tricky, but you should have already found out otherwise you wouldn't get that message.

Now, the Industruino 1286 programmer is not very verbose.

As it looks it is a wrap around a MT-CDC programmer and gives very little information.

The Device code 0x43 is just the USB device code of the Atmel 128x MCU's, so this message actually means download was ok.

I tried it with a serial example, so that I don't use any of the hardware, and it works perfectly.

Download, hti reset, get the 0x43 code, get what expected on serial.

So you should look around in your program to find out why it does not do what expected.

As an example, the USB in Leonardo hangs if no serial connected and you used the Leonardo USB workaround.

 

Stefano Giuseppe Bonvini
Stefano Giuseppe Bonvini
567
| 0 0 0
Answered on 9/8/16, 6:53 AM
0
vote

Dear,

It's the same thing with an empty project. This is what I've in boards.txt :

ind1286.name=Industruino 1286

ind1286.bootloader.low_fuses=0x7f
ind1286.bootloader.high_fuses=0x9a
ind1286.bootloader.extended_fuses=0xfb
ind1286.bootloader.path=ind1286
#ind1286.bootloader.path=caterina
ind1286.bootloader.file=ind1286\Bootloader.hex
ind1286.bootloader.unlock_bits=0x3F
ind1286.bootloader.lock_bits=0x2F

ind1286.build.board=usb1286
ind1286.build.mcu=at90usb1286
ind1286.build.f_cpu=16000000L
ind1286.build.core=Industruino
ind1286.build.variant=ind1286
ind1286.build.vid=0x16D0
ind1286.build.pid=0x0856
ind1286.build.usb_product="Industruino"
ind1286.build.usb_manufacturer="Industruino 1286"
ind1286.build.extra_flags={build.usb_flags}

ind1286.upload.tool=arduino:avrdude
ind1286.upload.protocol=avr109
ind1286.upload.maximum_size=126976
ind1286.upload.speed=57600
ind1286.upload.disable_flushing=true
ind1286.upload.use_1200bps_touch=true
ind1286.upload.wait_for_upload_port=true

ind1286.vid.0=0x16D0
ind1286.pid.0=0x0856

 

Cordially,

Guillem

Guillem Castellvi
Guillem Castellvi
7
| 0 0 0
Answered on 9/8/16, 6:00 AM
0
vote

Just had this issue in another post:

https://industruino.com/forum/help-1/question/arduino-ide-1-6-5-outputs-device-code-0x43-using-1286-topboard-203

As it looks, hardware definitons are different for each MCU and must be adapted.

In previous case, it was an interrupt definition.

In your case, please post your code, at least definitions and main routines, to check issues.

Stefano Giuseppe Bonvini
Stefano Giuseppe Bonvini
47
| 0 0 0
Answered on 9/7/16, 11:55 AM
0
vote

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

30 follower(s)

Stats

Asked: 9/7/16, 8:39 AM
Seen: 817 times
Last updated: 9/8/16, 6:53 AM