Connecting to Upload code via USB?

I have a D21G topboard, and am trying to upload my sketch to it, through the RS485 to USB connection. The device appears in the device manager as an "Unknown Device", under Universal Serial Bus Controllers. I try to install the driver from the site, and I get a notice saying windows has a better driver, and does not install it. If I just try to upload the code, I get an error saying "No device found on COM1". I have tried 2 different Industruinos, and 2 different computers, including one that has written code to another Arduino before. I have the correct libraries and topboard specified. I have run out of ideas on how to make this thing work, and I am using Windows 7.

Ryan Taylor
Ryan Taylor
7
| 0 0 0
Asked on 11/7/17, 5:41 PM
0
vote
169 Views

I am experiencing issues with uploading to the D21 topboard as well but it is not the missing com port issue.

I have installed the boards and com port driver as per the linked previous answer, and i can actually program the unit but I have to pull the cover off and click the reset button every time.   Is there no way to get the Arduino IDE to upload to the D21 without having to open the cover and press the reset?  Its buried inside an enclosure and difficult to get at.

The arduino IDE goes through the test/compile process and then finds the port and just sits there for 30 seconds saying "uploading" but the D21 does not flicker, and eventually the IDE times out on the upload.  Have tried multiple cables without change, and the cables will successfully upload if i press the physical reset button just as the compiling process finishes.

Russ
Russ
7
| 0 0 0
Answered on 2/21/18, 4:40 AM
0
vote

Hi Russ, that is strange. Does the port appear in your IDE? Do you select the port from Tools>Ports before uploading?

Tom
on 2/21/18, 5:01 AM
Yes to both.

Usually it auto-selects the port since there is usually only one port available at a time.  

The sketch will upload successfully if i double-click the reset button on the topboard.   I've never been able to upload any other way so far...  Had the D21 for a couple months now, playing with it in the evenings.

Cheers,
   Russ

On 2/20/2018 9:01 PM, Tom wrote:
<blockquote type="cite" cite="mid:1519189313.345211029052734.575092255379897-openerp-461-forum.post@ubuntu-odoo-feb">

Hi Russ, that is strange. Does the port appear in your IDE? Do you select the port from Tools>Ports before uploading?

--
Tom
Sent by Industruino using Odoo about Forum Post Connecting to Upload code via USB? (461)

Virus-free. www.avast.com
Russ
on 2/21/18, 5:24 AM

Hi Ryan,

You mention you installed the Industruino package in the Arduino IDE board manager, after you do this, you should be able to find 'Industruino D21G' in the list of boards (Tools>Board); select it.

Then use a standard USB cable to connect your Industruino (micro USB connector) to your computer, do not use the RS485 port.

Now the Industruino should show up in your device manager, and in the IDE under Tools>Port - select it and you're ready for upload.

In case you encounter a problem with the driver, please check this previous answer https://industruino.com/forum/help-1/question/early-d21g-adopter-need-some-documentation-326

Tom
Tom
5200
| 0 0 1
Answered on 11/7/17, 11:43 PM
0
vote

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

41 follower(s)

Stats

Asked: 11/7/17, 5:41 PM
Seen: 169 times
Last updated: 2/21/18, 4:40 AM