Topboard failure

Hello.

after programming IND I/O 1286 using Arduino 1.6.5, it became frozen. Tried to pull out USB to reset it. After that only green LED on topboard lights up, but LCD is left completely off. Also, I am not able to see Industruino serial port in Windows.

I've detached topboard and tried to connect it to PC over USB. The same thing happens - green LED lights up, LCD is blank and backlight stays off, also IND I/O can not be seen in Windows as COM port.

Tried to press the button on the topboard for a few seconds, after that LCD backlight turns on and off for a few times  (this event lasts for about 5 seconds), and during this time Industruino shows itself in Windows (as COM port). Unfortunatelly, after that, it dissapears again. As I repeat this the same thing happens over and over.

Nothing was physically burned, as it can be seen on the device boards.

Any suggestions, is there any permanent damage or it only needs to be flashed again? How could I do that?

Should I try to place another topboard or a new one can be damaged also?

Thanks for any advice!

Marko
Marko
7
| 0 0 0
Asked on 5/14/16, 12:16 AM
0
vote
753 Views

Hello Loic,

thanks, that solved the issue.

But since the sketch was successfully compiled in Arduino 1.6.5 r5, what means it is "corrupted"?
The code is rather short (compiled about 750 bytes), nothing special, I can send it to you - two classes responsible for measurement with two types of sensors (using Indio AnalogRead/Write) that are later called in setup (or before the loop) and measurement that continues in a loop (calling method that uses Indio.analogReadMode(pin, V10);).

I tried to change some parts of code, but the same thing happened again, so I had to restore the board again.
How can I know this won't happen again, and when it will happen (since the sketch is compiled without errors)?

Is there any kind of update for Indio library or bootloader (currently I have V1.4, using Arduino 1.6.5r5)?

Thanks for your quick support!

Regards,

Marko

Marko
Marko
7
| 0 0 0
Answered on 5/14/16, 7:37 AM
0
vote

Dear Marko, please send your sketch to connect@industruino.com so we can check. Thanks. Loic

Loic De Buck
on 5/14/16, 8:35 AM

Hi Marko,

It seems that you uploaded a corrupted sketch to the topboard which disabled the USB part during sketch operation. Please try to upload a standard sketch such as Blink whilst in bootloader mode (the 8 second period after startup when the screen flashes), this should restore the USB serial part. To make sure you manage to upload within that period, please keep the reset button pressed down until the sketch is fully compiled, releasing the button when the IDE starts the upload process (by enabling verbose mode in your Arduino IDE settings you can see more clearly when the IDE moves from compilation to upload process).

Best Regards,

Loic

Loic De Buck
Loic De Buck
1227
| 3 1 3
Answered on 5/14/16, 4:07 AM
0
vote

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

27 follower(s)

Stats

Asked: 5/14/16, 12:16 AM
Seen: 753 times
Last updated: 5/14/16, 7:50 AM