SoftwareSerial with OdriveRobotics

Hello there,

I am using the Industruino to read some analog output 0-10v from an industrial kuka robot. I am trying to use the Industruino to communicate with the motor control board from OdriveRobotics that has a library for use with arduino through serial communication (https://github.com/madcowswe/ODrive/tree/master/Arduino/ODriveArduino) . Unfortunatly it uses the SoftwareSerial library which I saw in a previous post on this forum is not supported by Industruino. I wonder if there is a way to use hardwareserial from Industruino to communicate with the Odrive board (by modifying the library or ino file for serial initializing)?

Thanks in advance for your help,

pak

pak
pak
24
| 0 0 0
Asked on 1/18/19, 9:18 AM
0
vote
333 Views






Ciao, sono fuori ufficio per motivi di salute, vi risponderò al mio rientro: 21/1. Per urgenze contattatemi al cellulare.

 

Thank you for your email. Due to sickness, I am currently out of the office and will probably be back on 21/1. I apologize for the delay and any inconvenience.
In urgent cases, please call me on my mobile.
Best regards
fabrizio
on 1/18/19, 9:19 AM

Hi,

The library is actually not specifically written for SoftwareSerial, but the example is.

You can modify it as follows:

  • comment out line 2 (#include ss)
  • comment out line 10 (initialise ss)
  • find/replace 'Serial' with 'SerialUSB' (case sensitive -- to use Serial Monitor with Industruino)
  • add a line before line 15: #define odrive_serial Serial1

Now the library will use the hardware 'Serial1' which is available on D10/D5

If you prefer to use 'Serial' on D0/D1 then you need to disconnect it from the RS485 port by moving the switch on the baseboard away from the RS485 terminals.

With the above modifications, the library example compiles, please let me know if it works.

Tom
Tom
5375
| 0 0 1
Answered on 1/18/19, 9:40 AM
1
vote

Hi Tom,

Thank you for your answer. Your suggestions worked to be able to upload the sketch on the Industruino and get the serial monitor to work.

However I did not manage to control the motor, Ive had the problem before with a regular arduino which was solved by connecting the Odrive ground to the arduino ground. I did that on the Industruino by connecting the ISO2  pin ground from the IDC to the Odrive GND but the problem remains. Somehow the serial communication between the Industruino and the Odrive is not happening (made sure to connect D10 to Odrive TX and D5 to Odrive RX). Do I have to connect a 24V power supply to the Industruino to be able to use the Serial communication? So far I have only connected the Odrive by USB to the computer.

I will do more testing on my side to try to narrow down the issue.

pak
pak
24
| 0 0 0
Answered on 1/18/19, 12:40 PM
0
vote

My tired brain did a mistake when powering the Industruino to my 24V PSU... I switched V+ and V- (really need to get different color cables next time...), now I do not get any LED inside the industruino after powering it correctly... still accessible via usb but i am affraid i have damaged the I/O side of the board.

pak
on 1/18/19, 1:01 PM

Hi, you have probably blown the fuse on the baseboard; i suggest you test the fuse and replace if necessary

Tom
on 1/19/19, 1:02 AM

Hi, Yes the nano fuse is blown, it looks like a nano fuse series 452 7A from littlefuse is that correct ? Thanks again

pak
on 1/19/19, 3:08 PM

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

54 follower(s)

Stats

Asked: 1/18/19, 9:18 AM
Seen: 333 times
Last updated: 1/18/19, 12:40 PM