Early D21G Adopter - Need some documentation

I just received my D21G topboard and am struggling to get it connected to the IDE.  Is there a quick start guide with IDE version requirements?  Board Definition? 

Also, in the absence of documentation, I plugged a micro USB cable into the port on the topboard and, while it powers up and runs through a demo of the LCD capabilities, the device does not show up in the Windows 10 Device Manager.  Question: Is this the correct method of connecting this board to my computer to upload sketches?

Thank you,

BBB.

Brett Bowden
Brett Bowden
7
| 0 0 0
Asked on 4/5/17, 1:52 AM
0
vote
608 Views

Dear Brett,

Please follow these instructions to install the board files for D21G board in the Arduino IDE:

CORE INSTALATION

Download the Arduino IDE (at least version 1.6.12) form the 'arduino.cc' site (*not* from the 'arduino.org' site), install it and the open it.

The core can be installed as a package by the Arduino IDE cores manager.  Add the following URL to the "Additional Boards Manager URLs" field of the Arduino IDE "File | Preferences" menu option:

   https://static.industruino.com/downloads/code/IndustruinoCores/IndustruinoSAMD/pkgdef/package_industruino_samd_index.json

After that open the "Boards Manager" and install the package called "Industruino SAMD Boards (32-bit ARM Cortex-M0+)", then restart the Arduino IDE.

 

WINDOWS DRIVER (not signed yet, not needed on Windows 10, will be signed in the coming days)

Download the driver from the following URL to your local hard drive and uncompress it:

   https://static.industruino.com/downloads/drivers/drivers-industruino-windows-0.0.1.zip

When the board is first connected to the Windows PC there will be a message stating that no suitable driver could be found for the peripheral.  Click on the message and point the wizard to use the driver that you downloaded locally.  This step is different in each Windows release, but there is always at some point an option to browse for the driver locally.

If the message does not appear then log as an administrator and open the Device Manager (also this step differs for each Windows version): the Industruino board should be highlighted with a yellow question mark: right click on it, select Properties, select the "Driver" tab, push "Update driver..." and follow the directions to browse for the driver locally.

In both cases don't try to download the driver from the Internet, it won't work.

CURRENT KNOWN ISSUES:

WINDOWS ISSUE

If after a sketch is uploaded on the board the port in the "Tools | Port" menu is not selected anymore, then select it again before you perform a new upload or you will get an upload error.

LINUX ISSUE

If a "port not found" or similar error is raised when a sketch is uploaded then try to upload it again until the upload is successful.

NOTES ON THE BOOTLOADER

1) The bootloader runs for 5 seconds after the board is powered on, reset or a sketch is uploaded (you can tell when the bootloader is runnin by the "breathing" of the LCD backlight).

2) The bootloader can be forced to run indefinitely until a new sketch is uploaded (or the board is powered off) by pressing the reset button twice (double tap).

 

NOTE ON POWER SUPPLY

Always use an external power supply unless you are powering the top board only with no other devices or modules connected.

Best Regards,

Loic

 

Loic De Buck
Loic De Buck
1227
| 3 1 3
Answered on 4/5/17, 9:57 AM
2
vote

Thank you! The double click on the reset button fixed my issue of the topboard not creating a Comm port. After that, it was just a matter of adding the correct board file then uploading a blank sketch and I'm back in business.

Brett Bowden
on 4/5/17, 11:47 PM

Trying to install the driver on Windows 8 gives me an error saying "A driver has been found but an error occured during installation. Third party INF file does not contain any information about digital signatures." - Rough translation. I've manually chosen which driver to install, but the same error occurs.

Rune Poulsen
on 4/20/17, 9:34 AM

Amazing the problems caused by bad USB cords.  I tried a different cable and "voila" my computer now sees my new D21G!  Now, on to programming....

BBB.

Brett Bowden
Brett Bowden
7
| 0 0 0
Answered on 4/5/17, 2:17 AM
0
vote

Hi Brett, thanks for the feedback. You will need to add the D21G board support in the IDE Board Manager, please have a look at https://industruino.com/page/techcentre for the .json link

Tom
on 4/5/17, 2:38 AM

Shoot, looks like I bricked it. I should have been more patient... Thinking that any M0 was like any other, I tried to program the topboard with some of the other options and while the Arduino Zero (Programming Port) seemed to program, now the board no longer gets assigned a Comm Port so I'm back to not being able to talk to it.

Brett Bowden
on 4/5/17, 3:02 AM

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

34 follower(s)

Stats

Asked: 4/5/17, 1:52 AM
Seen: 608 times
Last updated: 4/5/17, 5:35 PM